poj 1125&&zoj1082 floyd

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 23282 Accepted: 12738

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10


这是一道裸的floyd,基本就是用来熟悉一下模板的。题意:你的程序包含多组股票经纪人的输入数据。每组以股票经纪人的人数开始。接下来的几行是每个经纪人与其他人接触的一些信息,包括这些人都是谁,以及将讯息传达到他们所需的时间。每个经纪人与其他人接触信息的格式如下:开头的第一个数表示共有n个联系人,接下来就有n对整数。每对整数列出的第一个数字指的是一个联系人(例如,一个'1'是指编号1的人),其次是在传递一个信息给那个人时所采取分钟的时间。没有特殊的标点符号或空格规则。 
每个人的编号为1至经纪人数目。所花费的传递时间是从1到10分钟(含10分种)。股票经纪的人数范围是从1到100。当输入股票经纪人的人数为0时,程序终止。 
输出 
在对于每一组数据,你的程序必须输出一行,包括的信息有传输速度最快的人,以及在最后一个人收到消息后,所总共使用的时间(整数分钟计算)下面是代码:


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 1000000 //无穷大

using namespace std;

int a[101][101];
int num;

void floyd(){//标准的floyd 模板
    for(int k=1;k<=num;k++)
     for(int i=1;i<=num;i++)
        for(int j=1;j<=num;j++){
             if(a[i][k]+a[k][j]<a[i][j])
                 a[i][j]=a[i][k]+a[k][j];
        }
}

int main(){
    int i,j;
    int m, contact, time, minTime, max, person;
    while(scanf("%d",&num) && num){
          for(i=1;i<=num;i++)
              for(j=1;j<=num;j++){  //建立临界表
                  if(i!=j) a[i][j]=inf;//表示初始时和其他的都不相连
                  else     a[i][j]=0;//到自己的距离为0
              }
           for(i=1;i<=num;i++){
                scanf("%d",&m);
                for(j=1;j<=m;j++){
                    scanf("%d%d",&contact,&time);
                    a[i][contact]=time;//从i号经纪人传到该联系人的时间即为输入的时间
                }
           }
           floyd();
           minTime=inf;
           for(i=1;i<=num;i++){
               max=0;
               for(j=1;j<=num;j++){
                   if(a[i][j]>max)
                        max=a[i][j];
               }
               if(max<minTime){
                       minTime=max;
                       person=i;
               }
           }
           if(minTime!=inf)
              printf("%d %d\n",person,minTime);

           else
               printf("disjoint\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值