【算法练习】poj2392 space elevator 多重背包问题+二进制优化

                                                                                    Space Elevator

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14306 Accepted: 6831

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

 

题意:有n种石头,每个石头的高度hi,允许用的最高高度为ai,数量为ci,求能组合的最高高度。

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

struct block{
	int h;
	int a;
	int c;
};

bool compare(block  b1,block b2){
	return b1.a<b2.a;
}

block blk[401];
int main(){
	int K;
	while(cin>>K){
		memset(blk,0,sizeof(blk));
		for(int i=1;i<=K;i++){
	   		cin>>blk[i].h>>blk[i].a>>blk[i].c;
		}
		sort(blk+1,blk+K+1,compare);
	
		int index=0;
		int Hnew[4001];
		int Anew[4001];

		for(int i=1;i<=K;i++){
			for(int j=1;j<=blk[i].c;j<<=1){
				index++;
				Hnew[index]=j*blk[i].h;
				Anew[index]=blk[i].a;
				blk[i].c-=j;
			}
			
			if(blk[i].c>0){
				index++;
				Hnew[index]=blk[i].c*blk[i].h;
				Anew[index]=blk[i].a;
			}
		}
	
		int dp[40000]={0};
		memset(dp,0,sizeof(dp));
		for(int i=0;i<=index;i++){
			for(int j=Anew[i];j>=Hnew[i];j--){
				dp[j]=max(dp[j],dp[j-Hnew[i]]+Hnew[i]);
			}
		} 
		
		int max=0;
	    for(int i=1;i<=Anew[index];i++){
	    	if(max<dp[i]){
	    		max=dp[i];
	    	}
	    }
        cout<<max<<endl;
	
	//	cout<<dp[Anew[index]]<<endl;
	}
	
	
} 

思路:先给这些石头排个序,最高高度小的在前面,这样才能使得高度最大,然后再按多重背包来做,这样就可以了。

问题:我做这一题主要麻烦是结果的输出,一直以为输出的是dp[Anew[index]],其实因为本题的特殊性,上界一直在变动,因此需要像最终代码这样输出,找到最后一行中的最大值。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值