求i^k之和——HDU - 6027

45 篇文章 1 订阅
6 篇文章 0 订阅

You are encountered with a traditional problem concerning the sums of powers. 
Given two integers n and k. Let f(i)=i^{k}, please evaluate the sum= f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of nn in this question is quite large. 
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 10^{9}+7.

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases. 
Each of the following T lines contains two integers n(1≤n≤10000)and k(0≤k≤5)

Output

For each test case, print a single line containing an integer modulo 10^{9}+7.

Sample Input

3
2 5
4 2
4 1

Sample Output

33
30
10

题解:

快速幂求a^n的值,再在主函数中调用。

由于数值比较大,用  long long  型数

代码:

#include<stdio.h>
long long pow(int a,int n)
{//返回a^n
    long long result=1,flag=a;
	while(n)
	{
		if(n&1)
		result=result*flag%1000000007;
		flag=flag*flag%1000000007;
		n/=2;
	 } 
	 return result%1000000007;
}
int main()
{
	int t,n,k;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		long long sum=0;
		scanf("%d %d",&n,&k);
		for(i=1;i<=n;i++)
		{
			sum+=pow(i,k)%1000000007;
		 } 
		 printf("%lld\n",sum%1000000007);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值