Easy Summation

 

You are encountered with a traditional problem concerning the sums of powers. 
Given two integers nn and kk. Let f(i)=ikf(i)=ik, please evaluate the sum f(1)+f(2)+...+f(n)f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of nnin this question is quite large. 
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7109+7.

InputThe first line of the input contains an integer T(1≤T≤20)T(1≤T≤20), denoting the number of test cases. 
Each of the following TT lines contains two integers n(1≤n≤10000)n(1≤n≤10000) and k(0≤k≤5)k(0≤k≤5). 
OutputFor each test case, print a single line containing an integer modulo 109+7109+7.Sample Input

3
2 5
4 2
4 1

Sample Output

33
30
10

 

题意:例第一组就是1的5次方加2的5次方(用快速幂)

#include <iostream>
#include<algorithm>
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
long long int f(long long int n,long long int k)
{
    long long int ans=1;
    while(k!=0)
    {
        if(k&1)
            ans=(n%1000000007)*(ans%1000000007);
        n=((n%1000000007)*(n%1000000007))%1000000007;
        k>>=1;
    }


    return ans;
}
int main()
{
    long long int T;
    scanf("%lld",&T);
    while(T--)
    {
        long long int n,k,i,sum=0;
        scanf("%lld%lld",&n,&k);
        for(i=1;i<=n;i++)
        {
            sum+=f(i,k)%1000000007;
        }
        printf("%lld\n",sum%1000000007);
    }
    return 0;
}

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值