HDU steps 1.3.4 shǎ崽 OrOrOrOrz (int数组快排实现)

shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3942 Accepted Submission(s): 1224

Problem Description
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen . 
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
 

Input
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
 

Output
Output a sequence of distinct integers described above.
 

Sample Input
5
1 2 3 4 5
 

Sample Output
5 1 4 2 3
 

Author
WhereIsHeroFrom
 

Source
HDU女生专场公开赛——谁说女子不如男
 

Recommend
lcy
分析: 这个题目基本思路 先排序(注意由于测试数据较多,一定要使用快排,可以自己写,可以调用库函数),然后输出一个最大的、输出一个最小的一次输出。

代码:

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		int n;
		Scanner in = new Scanner(System.in);
		while (in.hasNext()) {
			n = in.nextInt();
			int[] a = new int[n];
			for (int i = 0; i < n; i++) {
				a[i]=in.nextInt();
			}
			Arrays.sort(a);
//			int f = 1;                //这种输出方法超时。 这个f(n)=n; 下面的输出方法 f(n)=n/2
//			int k=0,t=n-1;
//			for (int i = 0; i <n; i++) {
//				if(f==1){System.out.print(a[t--]);f=0;}
//				else {
//					System.out.print(a[k++]); k++; f=1;
//				}
//				if(i!=n-1){System.out.print(" ");}
//			}
//			System.out.println();

			if(n%2==0){
				int i=0,j=n-1;
				while(j-i>1){
					System.out.print(a[j--]+" "+a[i++]+" ");
				}
				System.out.print(a[j]+" "+a[i]);
			}
			else{
				int i=0,j=n-1;
				while(j>i){
					System.out.print(a[j--]+" "+a[i++]+" ");
				}
				System.out.print(a[j]);
			}
			System.out.println();
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值