HDU shǎ崽 OrOrOrOrz

Problem Description
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3

Input
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.

Output
Output a sequence of distinct integers described above.

Sample Input
  
  
5 1 2 3 4 5

Sample Output
  
  
5 1 4 2 3
#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n,l;
    int a[10000];
    while(cin>>n)
    {
        for(int i=0; i<n; i++)
        {
            cin>>a[i];
        }
        sort(a,a+n,cmp);
        for(int i=0,j=0,k=n-1; i<n; i++)
        {
            //这里我定义了j和k,代表了数组的头和尾,当i为偶数时,输出头,并且头+1
            //当i为奇数时,输出尾,并且尾-1,用i记录输出的次数,当i=n时跳出循环
            if(i%2==0)
            {
                cout<<a[j];
                j++;
            }
            else
            {
                cout<<a[k];
                k--;
            }
            if(i!=n-1)
                cout<<" ";
            else
                cout<<endl;
        }
    }
    //cout<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值