POJ - 3669 Meteor Shower (广搜+标记)

Meteor Shower

  POJ - 3669 

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5
 
 
 
 
题意:
    要下流星雨,给个整数M,表示有M颗流星,接下来有M组数据,每组数据三个正整数,前两个表示这颗流星落下的坐标(坐标全在第一象限内),第三个表示落下的时间,流星落下时会将自身坐标和周围上下左右四个点总共五个位置给炸毁。Bessie在时间为零时从坐标原点出发,每单位时间内可以往她周围上下左右四个方向走一步(当然也是在第一象限内),求她到达安全地点(就是不会被流星炸毁的地方)的最短时间。如果不能够找到一个安全的地方,输出“-1”。
 
 
解题思路:
    求最短时间,应该想到用广度搜索,这题其实就是在基础广搜的基础上,对地图进行一个标记,标记流星炸毁的最早的时间,更新流星炸毁时间时,图内更新的应该是流星将这一地区炸毁的最早时间。广搜时判断一下到达这个点时是否流星已经将这个地点炸毁,若没有炸毁,将这个点加入队列继续搜索,直到搜索到一个从始至终没有被流星炸毁的地方,就表明Bessie到达了安全的地方。
 
 
注意:
    刚开始应该将地图初始化一下,初始化流星炸毁的时间,但是不能初始化为0,因为时间是从0开始,可能有些流星在时间为0时就炸毁了。若判断坐标是否出界,上限不是300,起码得是303,因为可能坐标包含300的流星会将坐标为301的地方炸毁,Bessie需要走到坐标为302的地方才算安全。流星炸毁的地点包括它本身的位置。还有就是可能坐标原点就是安全的地点,在进入广搜时应该单独判断一下。
 
 
AC代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

int mp[500][500], minn, flag;
int book[500][500];
int nx[5][2]= {{0,-1},{-1,0},{0,1},{1,0},{0,0}};

struct node       //存入流星炸毁的坐标,时间
{
    int x;
    int y;
    int temp;
};

void bang( int x, int y, int t ) //标记流星炸毁的坐标和更新最早的炸毁时间
{
    for( int i = 0; i < 5; i++ ) //记得还有本身也需要炸毁
    {
        int tx = x + nx[i][0];
        int ty = y + nx[i][1];
        if( tx<0 || ty<0 )       //若判断上限应该起码为303
            continue;
        if( mp[tx][ty] == -1 )
            mp[tx][ty] = t;
        else
            mp[tx][ty] = min(t,mp[tx][ty]);//保存流星炸毁的最早时间
    }
}

void bfs( )
{
    queue<node>Q;
    node now, stp;
    now.x = 0;    //初始坐标为0 0
    now.y = 0;
    now.temp = 0; //时间也是从0开始
    Q.push(now);
    while( !Q.empty() )
    {
        now = Q.front();
        Q.pop();
        if( mp[now.x][now.y] == -1 )
        {
            flag = 1;
            minn = now.temp;   //若原点就是安全的地点
            return ;           // 记录步数直接返回
        }
        for( int i = 0; i < 4; i++ )
        {
            int tx = now.x + nx[i][0];
            int ty = now.y + nx[i][1];
            if( tx<0 || ty<0 )
                continue;
            if( mp[tx][ty] == -1 )  //找到安全的地点
            {
                flag = 1;
                minn = now.temp + 1;
                return ;
            }
            if( now.temp+1 < mp[tx][ty] && !book[tx][ty] )
            {                        //可以走的坐标
                book[tx][ty] = 1;
                stp.x = tx;
                stp.y = ty;
                stp.temp = now.temp + 1;
                Q.push(stp);
            }
        }
    }
}

int main()
{
    int m;
    while( ~scanf("%d",&m) )
    {
        int x1, y1, t1;
        memset(mp,-1,sizeof(mp));
        for( int i = 0; i < m; i++ )
        {
            scanf("%d%d%d",&x1,&y1,&t1);
            bang(x1,y1,t1);   //标记流星爆炸
        }
        flag = 0;
        memset(book,0,sizeof(book));
        book[0][0] = 1;
        bfs();
        if( flag )
            printf("%d\n",minn);
        else
            printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值