1100 Mars Numbers (20分)

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13
#include <iostream>
#include <string>

using namespace std;

string high[] = { "","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" },
low[] = { "tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };

void fun1(int n)
{
	if (n / 13 != 0)
	{
		cout << high[n / 13];
	}
	if (n / 13 != 0 && n % 13 != 0)
	{
		cout << " ";
	}
	if (n % 13 != 0 || n == 0)
	{
		cout << low[n % 13];
	}
}

void fun2(string s)
{
	int t1 = 0, t2 = 0;
	string s1 = s.substr(0, 3), s2;
	if (s.length() > 4)//两位火星数字 ,获取低位
	{
		s2 = s.substr(4, s.length()-1);
		//s2=s.substr(4,3);也可以:3代表截取三个字符
	}
	for (int i = 0; i < 13; i++)
	{//我的思路是s1要在high和low中都要进行查找,从s1出发的遍历两个数组去查看是否和s1相等,程序复杂。liuchuo是从数组出发的,很巧妙而且程序简单。角度不同
		if (high[i] == s1)//高位只能用于查看s1
		{
			t1 = i;
		}
		if (low[i] == s1 || low[i] == s2)//低位里面可以查看s1(只有一位的火星数字情况)和s2(两位的火星数字情况)
		{
			t2 = i;
		}
	}
	cout << t1 * 13 + t2;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int times;
	scanf("%d\n", &times);
	for (int i = 0; i < times; i++)
	{
		string s;
		getline(cin, s);
		if (s[0] <= '9'&&s[0] >= '0')
		{
			fun1(stoi(s));
		}
		else
		{
			fun2(s);
		}
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值