1148 Werewolf - Simple Version (20分) 思维题 模拟 很重要 细节和 思维转换

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

 大意:狼人杀游戏,有n个人,其中有两个狼人,两个说谎人,第i行的值就是第i个人陈述的话,值就是第i个人描述的那个人,负值即第i个人描述那人是狼,反之是人。问哪两个是狼?

柳:

#include <iostream>
#include <vector>

using namespace std;

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	vector<int> v(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> v[i];
	}
	for (int i = 1; i <= n; i++)
	{
		for (int j = i + 1; j <= n; j++)
		{
			vector<int> lie, a(n + 1, 1);
			a[i] = a[j] = -1;
			for (int k = 1; k <= n; k++)
			{
				if (v[k] *a[abs(v[k])] < 0)
				{
					lie.push_back(k);
				}
			}
			if (lie.size() == 2 && a[lie[0]] + a[lie[1]] == 0)
			{
				cout << i << " " << j << endl;
				return 0;
			}
		}
	}


	cout << "No Solution";

	return 0;
}

二刷:还是没有这个思维   柳的思路

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	
	vector<int> v(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> v[i];
	}
	vector<int> ans;
	bool flag = false;
	for (int i = 1; i <= n; i++)
	{
		for (int j = i+1; j <= n; j++)
		{
			vector<int> status(n + 1,1);
			status[i] = -1;
			status[j] = -1;
			vector<int> liar;
			for (int t = 1; t <= n; t++)
			{
				if (v[t]*status[abs(v[t])]<0)
				{
					liar.push_back(t);
				}
			}
			if (liar.size()==2&&status[liar[0]]+status[liar[1]]==0)
			{
				ans.push_back(i);
				ans.push_back(j);
				flag = true;
				break;
			}
		}
		if (flag)
		{
			break;
		}
	}
	if (ans.empty())
	{
		cout << "No Solution" << endl;
	}
	else
	{
		cout << ans[0] << " " << ans[1] << endl;
	}
	
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值