PAT顶级1022 Werewolf(甲级1148升级版)

PAT顶级1022 Werewolf(甲级1148升级版)

题目:

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder vertion of this problem: given that there were N players, with M werewolves among them, at least one but not all the werewolves were lying, and there were exactly L liars. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integer N (5 ≤ N ≤ 100), M and L (2 ≤ M,L < N). Then N lines follow and the i-th line gives the statement of the i-th player (1 ≤ i ≤ N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in descending order the indices of the M werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the largest solution sequence – that is, for two sequences A = { a[1], …, a[M] } and B = { b[1], …, b[M] }, if there exists 0 ≤ k < M such that a[i] = b[i] (i ≤ k) and a[k+1]>b[k+1], then A is said to be larger than B. In case there is no solution, simply print No Solution.

Sample Input 1:
5 2 2
-2
+3
-4
+5
+4
Sample Output 1:
4 1

Sample Input 2:
6 2 3
-2
+3
-4
+5
+4
-3
Sample Output 2:
6 4

Sample Input 3:
6 2 5
-2
+3
-4
+5
+4
+6
Sample Output 3:
No Solution

题目大意:

本题是甲级1148的升级版,狼人数量和说谎人数都是随便给一个值m,l;不再是甲级中固定的2人,所以本题考虑深度优先搜索,枚举狼人,同时记录狼人数量,当枚举到的狼人数量与给定m相同时去检验每一个人的描述,再验证说谎人数和说谎狼人数,若符合条件则返回,因要求输出符合要求最大的一组数,故选择从最后一个人开始枚举。

AC代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn=111;
vector<int> liar,ans,temp;
int n,m,l,flag,state[maxn],id[maxn];
void DFS(int now,int num)
{
    if(num==m&&flag==0)
    {
    	temp.push_back(now);
    	id[now]=-1;
        int cnt=0;
        liar.clear();
        for(int i=1;i<=n;i++)
        {
            if(state[i]*id[abs(state[i])]<0)
            {
                liar.push_back(i);
                if(id[i]==-1) cnt++;
            }
        }
        if(liar.size()==l&&cnt>=1&&cnt<m) { ans=temp; flag=1; }
        id[now]=1;
        temp.pop_back();
    }
    if(num>m||now<1||flag==1) return;
    temp.push_back(now);
    id[now]=-1;
    DFS(now-1,num+1);
    id[now]=1;
    temp.pop_back();
    DFS(now-1,num);
}
int main()
{
    cin>>n>>m>>l;
    for(int i=1;i<=n;i++) cin>>state[i];
    fill(id,id+maxn,1);
    DFS(n,1);
    if(ans.size()==0) printf("No Solution");
    else
    {
        for(int i=0;i<ans.size();i++)
        {
        	if(i!=0) cout<<" ";
            printf("%d",ans[i]);
        }
    }
    return 0;
}
  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值