PAT甲级1148 Werewolf - Simple Version

1148
柳神

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: "Player #2 is a werewolf.";
player #2 said: "Player #3 is a human.";
player #3 said: "Player #4 is a werewolf.";
player #4 said: "Player #5 is a human."; and
player #5 said: "Player #4 is a human.".
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:
If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:
5
-2
+3
-4
+5
+4
结尾无空行
Sample Output 1:
1 4
结尾无空行
Sample Input 2:
6
+6
+3
+1
-5
-2
+4
结尾无空行
Sample Output 2 (the solution is not unique):
1 5
结尾无空行
Sample Input 3:
5
-2
-3
-4
-5
-1
结尾无空行
Sample Output 3:
No Solution
结尾无空行

双重循环,每次循环确定两个人为狼,其余人假定为人类,然后再去找撒谎的人。当撒谎的人有两个而且一个是人类一个是狼时满足条件,题目中要求的当有多个解决方案时,输出第一个狼索引较小的一组,这一点通过从小索引到大索引来实现。

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int main(){
    int n;
    cin >> n;
    vector<int> state(n + 1);
    for(int i = 1;i <= n;++i){
        cin >> state[i];
    }
    for(int i = 1;i <= n - 1;++i){
        for(int j = i + 1;j <= n;++j){
            vector<int> liar,res(n + 1,1);
            res[i] = res[j] = -1;
            for(int k = 1;k <= n;++k){
                if(state[k] * res[abs(state[k])] < 0){
                    liar.push_back(k);
                }
            }
            if(liar.size() == 2&&res[liar[0]] + res[liar[1]] == 0){
                cout << i << ' ' << j << endl;
                return 0;
            }
        }
    }
    cout << "No Solution" << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值