1053 Path of Equal Weight (30分) 附加条件的 树的遍历(dfs)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

 吾:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;




struct node
{
	int id, weight;
	vector<int> children;
};



vector<int> path;
int n, m, s;
vector<node> input;

bool cmp1(int n1, int n2)
{
	return input[n1].weight > input[n2].weight;
}

void dfs(node root,int sum)
{
	if (sum>s)
	{
		
		return;
	}
	if (sum==s)
	{
		if (root.children.size()!=0)
		{
			
			return;
		}
		int size = path.size();
		for (int i = 0; i < size; i++)
		{
			if (i!=0)
			{
				cout << " ";
			}
			cout << input[path[i]].weight;
			
		}
		cout << endl;		
		return;
	}
	
	
	int size = root.children.size();
	for (int i = 0; i < size; i++)
	{
		path.push_back(input[root.children[i]].id);
		dfs(input[root.children[i]], sum+ input[root.children[i]].weight);
		path.pop_back();//不管哪种情况return,就算每条路都小于s,返回的时候也得pop一下,所以pop语句放在这里,之前逻辑没想好,放在return之前,那样只有sum大于和等于s时候才会pop,实际上小于s的时候也得pop

	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	
	cin >> n >> m >> s;
	input.resize(n);
	for (int i = 0; i < n; i++)
	{
		cin >> input[i].weight;
		input[i].id = i;
	}
	for (int i = 0; i < m; i++)
	{
		int id, k,cId;
		cin >> id >> k;
		input[id].children.resize(k);
		for (int j = 0; j < k; j++)
		{
			cin >> input[id].children[j];
		}
		//排序把孩子中weight大的放在前面,遍历的时候也是先遍历了weight大的线路,自然输出path的时候是从大到小的。这是很巧妙的小技巧!!!
		sort(input[id].children.begin(), input[id].children.end(), cmp1);
	}
	path.push_back(0);
	dfs(input[0],input[0].weight);
	return 0;
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值