PAT (Advanced Level) 1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.
    If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
    Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#include <functional>
#pragma warning(disable:4996)

using namespace std;

vector<int> pre, in;
bool ft = true;
int n, cnt = 0;

struct Node
{
	int key;
	Node *lchild, *rchild;
	Node() { lchild = rchild = nullptr; }
};

Node* buildTree_t(int preL, int preR, int inL, int inR) //左闭右开
{
	if (preL >= preR || !ft)
		return nullptr;
	int k = lower_bound(in.begin() + inL, in.begin() + inR, pre[preL]) - in.begin();
	if (k >= inR)
	{
		ft = false;
		return nullptr;
	}
	Node* root = new Node;
	root->key = pre[preL];
	root->lchild = buildTree_t(preL + 1, preL + k - inL + 1, inL, k);
	root->rchild = buildTree_t(preL + k - inL + 1, preL + inR - inL, k + 1, inR);
	return root;
}
Node* buildTree_r(int preL, int preR, int inL, int inR) //左闭右开
{
	if (preL >= preR || !ft)
		return nullptr;
	int k = upper_bound(in.begin() + inL, in.begin() + inR, pre[preL], greater<int>()) - in.begin() - 1;
	if (in[k] != pre[preL])
	{
		ft = false;
		return nullptr;
	}
	Node* root = new Node;
	root->key = pre[preL];
	root->lchild = buildTree_r(preL + 1, preL + k - inL + 1, inL, k);
	root->rchild = buildTree_r(preL + k - inL + 1, preL + inR - inL, k + 1, inR);
	return root;
}

void postorder_traversal(Node* node)
{
	if (node == nullptr)
		return;
	postorder_traversal(node->lchild);
	postorder_traversal(node->rchild);
	cnt++;
	printf("%d%c", node->key, (cnt == n ? '\n' : ' '));
}

int main()
{
	scanf("%d", &n);
	pre.resize(n); in.resize(n);
	for (int i = 0; i < pre.size(); i++)
		scanf("%d", &pre[i]);
	in.assign(pre.begin(), pre.end());
	sort(in.begin(), in.end());
	Node* head = buildTree_t(0, n, 0, n);
	if (ft)
	{
		printf("YES\n");
		postorder_traversal(head);
	}
	else
	{
		ft = true;
		sort(in.begin(), in.end(), [](const int& n1, const int& n2) {
			return n1 > n2;
		});
		head = buildTree_r(0, n, 0, n);
		if (ft)
		{
			printf("YES\n");
			postorder_traversal(head);
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}

思路:

由先序遍历和中序遍历构建二叉树,再后序遍历

以下是用 C 语言实现的代码: ```c #include <stdio.h> #include <stdbool.h> #include <stdlib.h> /* 二叉树结点 */ struct TreeNode { int val; struct TreeNode* left; struct TreeNode* right; }; /* 队列结点 */ struct QueueNode { struct TreeNode* data; struct QueueNode* next; }; /* 队列 */ struct Queue { struct QueueNode* front; struct QueueNode* rear; }; /* 创建队列 */ struct Queue* createQueue() { struct Queue* queue = (struct Queue*)malloc(sizeof(struct Queue)); queue->front = queue->rear = NULL; return queue; } /* 判断队列是否为空 */ bool isQueueEmpty(struct Queue* queue) { return queue->front == NULL; } /* 入队 */ void enqueue(struct Queue* queue, struct TreeNode* data) { struct QueueNode* newNode = (struct QueueNode*)malloc(sizeof(struct QueueNode)); newNode->data = data; newNode->next = NULL; if (isQueueEmpty(queue)) { queue->front = queue->rear = newNode; } else { queue->rear->next = newNode; queue->rear = newNode; } } /* 出队 */ struct TreeNode* dequeue(struct Queue* queue) { if (isQueueEmpty(queue)) { return NULL; } else { struct TreeNode* data = queue->front->data; struct QueueNode* temp = queue->front; queue->front = queue->front->next; if (queue->front == NULL) { queue->rear = NULL; } free(temp); return data; } } /* 判断是否为完全二叉树 */ bool isCompleteTree(struct TreeNode* root) { if (root == NULL) { return true; } struct Queue* queue = createQueue(); enqueue(queue, root); bool flag = false; while (!isQueueEmpty(queue)) { struct TreeNode* temp = dequeue(queue); if (temp->left) { if (flag) { return false; } enqueue(queue, temp->left); } else { flag = true; } if (temp->right) { if (flag) { return false; } enqueue(queue, temp->right); } else { flag = true; } } return true; } /* 创建二叉树 */ struct TreeNode* createTree() { int val; scanf("%d", &val); if (val == -1) { return NULL; } struct TreeNode* root = (struct TreeNode*)malloc(sizeof(struct TreeNode)); root->val = val; root->left = createTree(); root->right = createTree(); return root; } /* 主函数 */ int main() { struct TreeNode* root = createTree(); if (isCompleteTree(root)) { printf("It is a complete binary tree.\n"); } else { printf("It is not a complete binary tree.\n"); } return 0; } ``` 原理: 完全二叉树(Complete Binary Tree)是指除了最后一层外,其他层的结点数都达到了最大值,最后一层的结点都集中在左侧。而对于一棵二叉树,如果它的层数为 h,那么它最多有 $2^h-1$ 个结点。因此,我们可以利用层序遍历的方式,对二叉树进行遍历,如果遇到某个结点缺少左子结点或右子结点,那么后续的结点必须全部为叶子结点,否则这棵二叉树就不是完全二叉树。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值