1118 Birds in Forest (25分) 简单并查集

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

 大意:n张图,每张图片里k只鸟都是一棵树上的。问共有几棵树,几只鸟?

 一刷:柳

#include <iostream>
#include <vector>

using namespace std;

constexpr auto maxn = 10001;
vector<int> father(maxn),cnt(maxn,0);

int find(int x)
{
	/*if (x=father[x])//含路径压缩的find
	{
		return x;
	}
	return father[x] = find(father[x]);*/

	//第二种方式的find   好好弄懂两者的区别,第二种find是对的在本题中,区别只在于这find函数中
	int a = x;
	while (x != father[x])
		x = father[x];
	while (a != father[a]) {
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}

void merge(int a, int b)
{
	int fA = find(a), fB = find(b);
	if (fA!=fB)
	{
		father[fB] = fA;
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n,k,trees=0,birds=0;
	cin >> n;
	vector<bool> exist(maxn);
	
	for (int i = 0; i < maxn; i++)
	{
		father[i] = i;
	}
	for (int i = 0; i < n; i++)
	{
		cin >> k;
		int temp;
		cin >> temp;
		exist[temp] = true;
		for (int j = 1; j < k; j++)
		{
			int id;
			cin >> id;
			exist[id] = true;
			merge(id, temp);
			temp = id;
		}
	}
	//处理数据,得到树和鸟的数量
	for (int i = 0; i < maxn; i++)
	{
		if (exist[i])
		{
			int root = find(i);
			cnt[root]++;
		}
	}
	for (int i = 0; i < maxn; i++)
	{
		if (exist[i]&&cnt[i]!=0)
		{
			trees++;
			birds += cnt[i];
		}
	}
	cout << trees << " " << birds << endl;
	int q;
	cin >> q;
	for (int i = 0; i < q; i++)
	{
		int a, b;
		cin >> a >> b;
		if (find(a)==find(b))
		{
			cout << "Yes";
		}
		else
		{
			cout << "No";
		}
		cout << endl;
	}
	return 0;
}

 二刷:吾:

#include <iostream>
#include <vector>

using namespace std;

const int maxn = 10006;
vector<int> father(maxn),isroot(maxn,0);

int findfather(int x)
{
	return x == father[x] ? x : father[x] = findfather(father[x]);
}

void Union(int a, int b)
{
	int fa = findfather(a), fb = findfather(b);
	if (fa!=fb)
	{
		father[fa] = fb;
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, k;
	cin >> n;
	bool visit[maxn] = { false };
	for (int i = 0; i < maxn; i++)
	{
		father[i] = i;
	}
	for (int t = 0; t < n; t++)
	{
		cin >> k;
		int bird;
		cin >> bird;
		visit[bird] = true;
		for (int i = 1; i < k; i++)
		{
			int temp;
			cin >> temp;
			visit[temp] = true;
			Union(bird, temp);
		}
	}
	
	for (int i = 0; i < maxn; i++)
	{
		if (visit[i])
		{
			int root = findfather(i);
			isroot[root]++;
		}
	}
	int treecnt = 0,birdscnt=0;
	for (auto c : isroot)
	{
		if (c!=0)
		{
			treecnt++;
			birdscnt += c;
		}
	}
	cout << treecnt << " " << birdscnt << endl;
	int q;
	cin >> q;
	for (int i = 0; i < q; i++)
	{
		int a, b;
		cin >> a >> b;
		printf("%s\n", (findfather(a) == findfather(b)) ? "Yes" : "No");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均达到96,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均达到96,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值