1118 Birds in Forest(25 分)

1118 Birds in Forest(25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

 

裸并查集

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e4+10;
int pre[maxn];
int a[maxn];
set<int>st;
int find(int x)
{
	if(x==pre[x])
		return x;
	else 
		return pre[x] = find(pre[x]);
}
void merge(int x,int y)
{
	int fx = find(x);
	int fy = find(y);
	if(fx != fy)
		pre[fx]  = fy;
}
int main()
{
	int n,k,x,y;
	scanf("%d",&n);
	for(int i = 1;i<=maxn-9;i++)
		pre[i] = i;
	for(int i = 1; i <= n;i++)
	{
		scanf("%d",&k);
		for(int j = 1; j <= k;j++)
		{
			scanf("%d",&a[j]);
			st.insert(a[j]); 
		}	
		for(int j = 2; j <= k;j++)
			merge(a[1],a[j]);
	}
	scanf("%d",&k);
	int cnt = 0;
	for(int i =1 ;i <= maxn-9;i++)
	{
		pre[i] = find(i);
		if(pre[i] == i &&st.find(i)!=st.end())
			cnt++;
	}
	printf("%d %d\n",cnt,st.size());
	for(int i =1 ;i <= k;i++)
	{
		scanf("%d %d",&x,&y);
		int fx = pre[x];
		int fy = pre[y];
		if(fx != fy) 
			printf("No\n");
		else 
			printf("Yes\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值