1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

第三行给的那个顺序是指第二行中那些数的位置,如“6” 即第二行数据中第6个数,从0开始算。

吾思:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>

using namespace std;

struct programmer
{
	int weight, initialIndex,rank;
};

bool cmp(programmer a, programmer b)
{
	return a.weight > b.weight;
}

bool cmp1(programmer a, programmer b)
{
	return a.initialIndex < b.initialIndex;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, capacity;
	scanf("%d %d", &n, &capacity);
	vector<programmer> initial,v;
	vector<int> order;
	for (int i = 0; i < n; i++)
	{
		programmer p;
		cin >> p.weight;
		p.initialIndex = i;
		initial.push_back(p);
	}
	/*for (programmer p,int i=0; cin >> p.weight;i++)
	{
		p.initialIndex = i;
		initial.push_back(p);
	}*/
	/*for (int i = 0; i < n; i++)
	{
		int number;
		scanf("%d", &number);
		v.push_back(initial[number]);
	}*/
	for (int number;cin>>number;)
	{
		v.push_back(initial[number]);
	}
	initial.clear();
	while (v.size()>1)
	{
		vector<programmer> temp = v;
		v.clear();
		int rank;
		if (temp.size()%capacity!=0)
		{
			rank = temp.size() / capacity + 2;
		}
		else
		{
			rank = temp.size() / capacity+1;
		}
		for (decltype(v.size()) i=0,sz=temp.size();i!=sz; )
		{
			vector<programmer> sortArr;
			for (int j = 0; j < capacity&&i!=sz; j++,i++)
			{
				sortArr.push_back(temp[i]);
			}
			sort(sortArr.begin(), sortArr.end(), cmp);
			v.push_back(sortArr[0]);
			for (decltype(sortArr.size()) k = 1,szSort=sortArr.size(); k != szSort; k++)
			{
				sortArr[k].rank = rank;
				initial.push_back(sortArr[k]);
			} 
		}
	}
	if (v.size()==1)
	{
		v[0].rank = 1;
		initial.push_back(v[0]);
	}
	sort(initial.begin(), initial.end(), cmp1);
	for (int i=0;i<initial.size();i++)
	{
		printf("%d", initial[i].rank);
		if (i!=initial.size()-1)
		{
			printf(" ");
		}	
	}
	//fclose(stdin);
	return 0;
}

 柳婼:

#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
    int weight, index, rank, index0;
};
bool cmp1(node a, node b) {
    return a.index0 < b.index0;
}
int main() {
    int n, g, num;
    scanf("%d%d", &n, &g);
    vector<int> v(n);
    vector<node> w(n);
    for(int i = 0; i < n; i++)
        scanf("%d", &v[i]);
    for(int i = 0; i < n; i++) {
        scanf("%d", &num);
        w[i].weight = v[num];
        w[i].index = i;
        w[i].index0 = num;
    }
    queue<node> q;
    for(int i = 0; i < n; i++)
        q.push(w[i]);
    while(!q.empty()) {
        int size = q.size();
        if(size == 1) {
            node temp = q.front();
            w[temp.index].rank = 1;
            break;
        }
        int group = size / g;
        if(size % g != 0)
            group += 1;
        node maxnode;
        int maxn = -1, cnt = 0;
        for(int i = 0; i < size; i++) {
            node temp = q.front();
            w[temp.index].rank = group + 1;
            q.pop();
            cnt++;
            if(temp.weight > maxn) {
                maxn = temp.weight;
                maxnode = temp;
            }
            if(cnt == g || i == size - 1) {
                cnt = 0;
                maxn = -1;
                q.push(maxnode);
            }
        }
    }
    sort(w.begin(), w.end(), cmp1);
    for(int i = 0; i < n; i++) {
        if(i != 0) printf(" ");
        printf("%d", w[i].rank);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值