Count the string



It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 
s: "abab" 
The prefixes are: "a", "ab", "aba", "abab" 
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6. 
The answer may be very large, so output the answer mod 10007. 
Input
The first line is a single integer T, indicating the number of test cases. 
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab
Sample Output
6
#include<cstdio>
#include<cstring>
#include<cstdlib>
char a[200005];
int b[200005];
int next[200005];

void makenext(char *b,int m)
{
	next[0]=0;
	int k=0,i=1;
	while(i<m)
	{
		while(k>0&&b[k]!=b[i])
			k=next[k-1];
		if(b[i]==b[k])
			k++;
		next[i++]=k;
	}
}


int main()
{
	int T,i,j,l1,l2,t,sum,k;
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		memset(b,0,sizeof(b));
		scanf("%d",&k);
		scanf("%s",a);
		makenext(a,k);
		for(i=1;i<=k;i++)
		{
				b[i]=b[next[i-1]]+1;
		}
		for(i=1;i<=k;i++)
			sum=(sum+b[i])%10007;
		printf("%d\n",sum);
	}
  	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值