zoj1151 栈堆+立即输出


For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


对于每个单词列表,输出一个每个单词颠倒的行而不改变单词的顺序。



这个问题包含多个测试用例!


多输入的第一行是整数N,然后是空行,后面是N个输入块。 每个输入块都采用问题描述中指定的格式。 输入块之间有空行。


输出格式由N个输出块组成。 输出块之间有空行。

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


你会得到一些测试用例。 第一行包含一个正整数,表示要遵循的病例数量。 每个案例在包含由一个空格分隔的单词列表的行上给出,每个单词只包含大写和小写字母。

Output

For each test case, print the output on one line.


对于每个测试用例,在一行上打印输出。

Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

点击打开链接

//堆栈立即输出的方法 这题本身很简单但是在输入和输出有困难
//这个解法是我看别人的从别人写的注释看ta也花了不少脑筋;
//本题解法采用栈堆的特点先进后出
//本题跟栈的特点一样,很适合用栈,可以看出作者本人花了不少心思 
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
stack<char>z;
int main()
{
	int n,k;
	char a[1000];
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d",&n);
		getchar();
		while(n--)
		{
			gets(a);//输入一句话采用gets() 
			int l=strlen(a);
			int i=0;
			while(1)//用break;让永远为真的循环结束 
			{
				while(a[i]!=' '&&i<l)
				{
					z.push(a[i]);//运用栈先进后出的特点 
					i++; 
				}
				while(!z.empty() )
				{
					printf("%c",z.top() ) ;
					z.pop() ;
				}
				if(i!=l)
				{
					printf(" ");
					i++;
				}
				else
				break;
			}
			printf("\n");
		} 
		if(k)
		printf("\n");//不知道为什么要加这一句 
	}
	return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值