zoj2829

点击打开链接


Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

迈克非常幸运,因为他有两个美丽的数字,3和5.但他非常贪婪,以至于他想要无限美丽的数字。 所以他宣称任何可以被3或5除的正数都是美丽的数字。 给你一个整数N(1 <= N <= 100000),你能告诉迈克第N个美丽的数字吗?

Input

The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

输入包含一个或多个测试用例。 对于每个测试用例,都有一行包含整数N.

Output

For each test case in the input, output the result on a line by itself.

对于输入中的每个测试用例,单独输出结果。

Sample Input

1
2
3
4

Sample Output

3
5
6
9


本题有规律可循,多写数就会发现规律,每7组数一组,每组数之间规律相同

#include<cstdio>
int main()
{
	int a,b,c,n,sum1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n%7!=0)
		{
			a=n%7;//余数 
			b=n/7;//整数 
			c=15*b;
			if(a==1)
				c=c+3;
			else if(a==2)
				c=c+5;
			else if(a==3)
				c=c+6;
			else if(a==4)
				c=c+9;
			else if(a==5)
				c=c+10;
			else if(a==6)
				c=c+12;
			else if(c==7)
				c=c+15;
			printf("%d\n",c);
		}
		else
		{
			a=n/7;
			c=a*15;
			printf("%d\n",c);
		}
	}
	return 0;
}       

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值