1033 To Fill or Not to Fill

1033 To Fill or Not to Fill (25分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

解题思路:

这是一道贪心算法题,对于这道题,我们每次做决策的时候都分三种情况进行讨论:

从当前加油站出发,在满油箱情况下可以到达其他加油站,那么:

1)如果从后面可以到达的加油站里有比当前加油站油价便宜的加油站,那么只需要从当前加油站加足够开到更低油价加油站的油即可,之后在那个加油站加油更优惠

2)如果从右面可达加油站中找不出比当前油价更低的加油站,那么从当前加油站加满油,然后选择可达加油站中油价最低的那个,到那边继续进行下一轮的判断

从当前加油站出发,在加满油的情况下也找不到一个可达的加油站,那么:

3)我们无法到达目的地,算法结束

 

需要注意的是,我们需要在最后添加一个油价为0,并且距离为从起点到终点距离的一个加油站,这样算法最后就会选择这个加油站,如果油量不够的话,就会选择加一定量的油,使得汽车刚好可以到达终点。

#include <stdio.h>
#include <algorithm>
using namespace std;

const int maxn = 510;
const int INF = 1000000000;



struct station{
	double price;	//油价和距离起始点的距离 
	double dis;
}st[maxn];

//对加油站按照距离从小到大排序 
int cmp(station a, station b){
	return a.dis<b.dis;
}

int main(){
	//分别表示油箱的最大储量,两地之间距离,单位油箱所能走的距离和加油站个数 
	double Cmax, D, Davg;
	int n;
	scanf("%lf %lf %lf %d", &Cmax, &D, &Davg, &n);
	for(int i=0; i<n; i++){
		//输入油价和距离 
		scanf("%lf %lf", &st[i].price, &st[i].dis);
	}
	//数组最后放置终点,距离为D,油价为0 
	st[n].price = 0;
	st[n].dis = D;
	//对加油站排序
	sort(st, st+n, cmp);
	int now = 0;	//表示当前所在的加油站下标 
	//计算加满油后能走的最远距离
	double max = Davg*Cmax;
	double ans = 0.0;		//计算总费用
	double nowTank = 0.0;	//当前油箱油量 
	//如果第一个加油站距离不是0,则没法启动
	if(st[0].dis != 0){
		printf("The maximum travel distance = 0.00\n");
	} else {
		while(now<n){
			int k=-1;
			double pricemin = INF;
			//找出能走的最远距离范围内油价最小的加油站
			for(int i=now+1; i<=n && st[i].dis<=st[now].dis+max; i++){
				if(st[i].price < pricemin){
					pricemin = st[i].price;
					k = i;
					//找到了在行车距离内第一个比当前加油站油价低的加油站 
					if(pricemin < st[now].price){
						break;
					}
				}
			} 
			if(k==-1) break; 
			//计算从now到k所需要的油量 
			double need = (st[k].dis-st[now].dis)/Davg;
			//如果前面有油价更低的加油站,那么只需加到能够到达那个加油站的油就行 
			if(pricemin < st[now].price){
				if(nowTank<need){
					ans += (double)(need-nowTank)*st[now].price;
					nowTank = 0;	//到站后油箱就没油了 
				} else {
					nowTank -= need;
				}
			} else {	//否则,加满就行 
				ans += (double)(Cmax-nowTank)*st[now].price;
				nowTank = Cmax-need; 
			}
			now = k;	//到达加油站k,进入下一层的循环 
		}
		
		if(now == n){
			printf("%.2f\n", ans);
		} else {
			printf("The maximum travel distance = %.2f\n", st[now].dis+max);
		}
    }
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值