B1043. 输出PATest(20)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest….”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
/*
B1043
*/
int main()
{
    char str[10010];
    gets(str);
//    char str[10010]="redlesPayBestPATTopTeePHPereatitAPPT";
    int strLength=strlen(str);
    int hashTable[6]={0};
    for(int i=0;i<strLength;++i){
        if(str[i]=='P'){//可以用字典dict[6]={'P','A','T','e','s','t'}来简化代码
            hashTable[0]++;
        }
        else if(str[i]=='A'){
            hashTable[1]++;
        }
        else if(str[i]=='T'){
            hashTable[2]++;
        }
        else if(str[i]=='e'){
            hashTable[3]++;
        }
        else if(str[i]=='s'){
            hashTable[4]++;
        }
        else if(str[i]=='t'){
            hashTable[5]++;
        }
    }
    //设置一个sum变量记录总个数,可以简化代码
    while(hashTable[0]||hashTable[1]||hashTable[2]||hashTable[3]||hashTable[4]||hashTable[5]){
    //注意这里不要写成else if ,如果有多个else if,执行了其中一个或者第一个的if,剩下的就不执行了,也就是只执行一个,
    //而多个if每次都执行,就是执行一个if,如果满足条件,还要继续判断其他if。这两个区别很重要
        if(hashTable[0]>0){
            printf("P");
            hashTable[0]--;
        }
         if(hashTable[1]>0){
            printf("A");
            hashTable[1]--;
        }
                if(hashTable[2]>0){
            printf("T");
            hashTable[2]--;
        }
                if(hashTable[3]>0){
            printf("e");
            hashTable[3]--;
        }
                if(hashTable[4]>0){
            printf("s");
            hashTable[4]--;
        }
                if(hashTable[5]>0){
            printf("t");
            hashTable[5]--;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值