Radar Installation(贪心)

Language:
Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 88059 Accepted: 19733
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1

代码:

//就是把每个岛屿的圆心给求出来,前提得知
//道的是,只有当岛屿在圆上的时候,它才有更多的空间去包含其他的岛屿
//就用sqrt(d*d-arr[i].y(arr[i].y)),得到圆心后就把圆心进行排序,再把岛屿和圆心进
//行比较,如果可以包含在内,则继续添加岛屿,如果出现无法包含到一个
//圆心时,则需要再开一个圆心,以此类推
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

struct island{
    float x;//岛屿的横坐标
    float y;//岛屿的纵坐标
    float r;//圆心的横坐标
};

island arr[1000+10];

//将圆心按从小到大进行排序
bool compared(island a,island b)
{
    return a.r<b.r;
}

int main()
{
    int n,d,ans=1,cns=0;
    int flag=0;
    while(cin>>n>>d)
    {
        cns++;
        ans=1;
        flag=0;
        if(n==0 && d ==0)
            break;

        for(int i=0;i<n;i++)
        {
            cin >> arr[i].x >> arr[i].y;
            arr[i].r=arr[i].x+sqrt(d*d-arr[i].y*arr[i].y);//计算每个岛屿的圆心的横坐标
            if(arr[i].y>d)
                flag=1;
        }
        if(flag==1 || d<0)
        {
            cout << "Case " << cns << ": -1" <<endl;
            continue;
        }
        //给圆心进行排序
        sort(arr,arr+n,compared);

        float temp=arr[0].r;
        float a=0,b=0,c=0;
        for(int i=0;i<n;i++)
        {
            a=arr[i].x-temp;
            b=arr[i].y;
            if((a*a+b*b)>d*d)//该岛屿不在该圆心的范围内时,增加一个圆心(雷达),即该岛屿的圆心(雷达)
            {
                ans++;
                temp=arr[i].r;
            }
        }
        cout << "Case " << cns << ": " << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值