多校训练-Bubble Sort(树状数组+离散化)

Bubble Sort

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
    for(int j=N,t;j>i;—j)
        if(P[j-1] > P[j])
            t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case. 
 

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
 

Sample Input
  
  
2 3 3 1 2 3 1 2 3
 

Sample Output
  
  
Case #1: 1 1 2 Case #2: 0 0 0
Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
 

大致题意:给你一串数,求其在冒泡排序过程中任何一个数所经过的最右边的位置和最左边的位置差;
思路:求每一个数的逆序数,易知最左边的位置一定是出事位置减去该数的逆序数,(自己理解);
最大位置就比较简单了,当前位置和出事位置中最大的哪一个必为该说所能走的最右边位置。
#include <iostream>  
#include <string.h>  
#include <algorithm>  
#include <stdio.h>  
#include<math.h>
using namespace std;  
const int N = 500005;  
  
struct Node  
{  
    int v,order,x;  
};  
  
int n;  
int c[N];  
int aa[N];    //离散化后的数组  
Node a[N],t[N];    //树状数组  
  
int Lowbit(int x)  
{  
    return x & (-x);  
}  
  
void Update(int t,int val)  
{  
    for(int i=t; i<=n; i+=Lowbit(i))  
        c[i] += val;  
}  
  
int getSum(int x)  
{  
    int ans=0;  
    for(int i=x; i>0; i-=Lowbit(i))  
        ans += c[i];  
    return ans;  
}  
  
bool cmp(Node a,Node b)  
{  
    return a.v<b.v;  
}  
  
int main()  
{  
    int T,cases=0;
    scanf("%d",&T);
    while(T--)  
    {  
        scanf("%d",&n);
        //离散化  
        for(int i=1; i<=n; i++)  
        {  
            scanf("%d",&a[i].v);  
            a[i].order=i;  
            t[i]=a[i];
        }  
        sort(a+1,a+1+n,cmp);  
        for(int i=1; i<=n; i++)  
            aa[a[i].order]=i;  
        //树状数组求逆序数  
        memset(c,0,sizeof(c));  
        int ans=0;  
        for(int i=1; i<=n; i++)  
        {  
            Update(aa[i],1);  
            ans=i-getSum(aa[i]);  
            t[i].x=ans;
        } 
        sort(t+1,t+n+1,cmp);
        printf("Case #%d: ",++cases);
        for(int i=1;i<n;i++)
        {
        	if(t[i].order>i)
        	  printf("%d ",abs(t[i].x));
        	  else
        	  printf("%d ",abs(i-(t[i].order-t[i].x)));
		}
		if(t[n].order>(n))
        	  printf("%d\n",abs(t[n].x));
        	  else
        	  printf("%d\n",abs(n-(t[n].order-t[n].x)));
    }  
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值