Bubble Sort
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 0 Accepted Submission(s): 0
Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.
After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i) for(int j=N,t;j>i;—j) if(P[j-1] > P[j]) t=P[j],P[j]=P[j-1],P[j-1]=t;
After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.
Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.
limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.
limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.
Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.
Sample Input
2 3 3 1 2 3 1 2 3
Sample Output
Case #1: 1 1 2 Case #2: 0 0 0HintIn first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3) the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3 In second case, the array has already in increasing order. So the answer of every number is 0.
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include<math.h>
using namespace std;
const int N = 500005;
struct Node
{
int v,order,x;
};
int n;
int c[N];
int aa[N]; //离散化后的数组
Node a[N],t[N]; //树状数组
int Lowbit(int x)
{
return x & (-x);
}
void Update(int t,int val)
{
for(int i=t; i<=n; i+=Lowbit(i))
c[i] += val;
}
int getSum(int x)
{
int ans=0;
for(int i=x; i>0; i-=Lowbit(i))
ans += c[i];
return ans;
}
bool cmp(Node a,Node b)
{
return a.v<b.v;
}
int main()
{
int T,cases=0;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
//离散化
for(int i=1; i<=n; i++)
{
scanf("%d",&a[i].v);
a[i].order=i;
t[i]=a[i];
}
sort(a+1,a+1+n,cmp);
for(int i=1; i<=n; i++)
aa[a[i].order]=i;
//树状数组求逆序数
memset(c,0,sizeof(c));
int ans=0;
for(int i=1; i<=n; i++)
{
Update(aa[i],1);
ans=i-getSum(aa[i]);
t[i].x=ans;
}
sort(t+1,t+n+1,cmp);
printf("Case #%d: ",++cases);
for(int i=1;i<n;i++)
{
if(t[i].order>i)
printf("%d ",abs(t[i].x));
else
printf("%d ",abs(i-(t[i].order-t[i].x)));
}
if(t[n].order>(n))
printf("%d\n",abs(t[n].x));
else
printf("%d\n",abs(n-(t[n].order-t[n].x)));
}
return 0;
}