hdu5775Bubble Sort+数状数组求逆序数

装载请注明出处:http://blog.csdn.net/xtulollipop
Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input

2
3
3 1 2
3
1 2 3

Sample Output

Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

Author
FZU

Source
2016 Multi-University Training Contest 4
题意:一个序列,按冒泡排序的办法,从末尾到前扫,每次将相邻两个数如果,前边的那个大,则交换两个,问每个数的最右到最左的最大距离。
考虑数字x,数组的右边比x小的数的个数称为x的逆序数。那么x会往有方向移位那么多次。所以X得最右边是移位后的位置和它本来该到的位置x中的较大的那个。而它最左边的位置为它现在的位置与它要到的位置中较小的那个。

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
#include<cstring>

using namespace std;

const int maxn=100005;
int Tree[maxn];
int a[maxn];
int ans[maxn];

inline int lowbit(int x){
    return (x&-x);
}
void add(int x,int value){
    for(int i=x;i<maxn;i+=lowbit(i))
        Tree[i]+=value;
}
int get(int x){
    int sum=0;
    for(int i=x;i;i-=lowbit(i)) sum+=Tree[i];
    return sum;
}

int main(){
    int t;
    scanf("%d",&t);
    for(int fo=1;fo<=t;fo++){
        int n;
        scanf("%d",&n);
        memset(Tree,0,sizeof(Tree));

        for(int i=1;i<=n;i++) scanf("%d",&a[i]);

        for(int i=1;i<=n;i++){
            add(a[i],1);
            int l=min(i,a[i]);
            int r=max(a[i],i+a[i]-get(a[i]));
            ans[a[i]]=r-l;
        }
        printf("Case #%d:",fo);
        for(int i=1;i<=n;i++) printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值