1024 Palindromic Number 回文数

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>
#include <string>
#include <algorithm>
#include <stack>

using namespace std;

bool check(string str){
    bool flag = true;
    for(int i = 0  ; i < str.length() / 2 ; i ++ ){
        if(str[i] != str[str.length()-i-1]){
            flag = false;
            break;
        }
    }
    return flag;
}

string string_reverse(string str){
    reverse(str.begin(),str.end());
    return str;
}


string adder(string a, string b){
    string res;
    stack<char> skt_a;
    stack<char> skt_b;
    for(auto i : a){
        skt_a.push(i);
    }
    for(auto i : b){
        skt_b.push(i);
    }
    int smaller = skt_a.size() < skt_b.size() ? skt_a.size() : skt_b.size();
    int carry = 0;
    while(smaller--){
        int ia = skt_a.top() - '0';
        int ib = skt_b.top() - '0';
        res = (char)((ia + ib + carry) % 10 + '0') + res;
        carry = (ia + ib +carry) / 10;
        skt_a.pop();
        skt_b.pop();
    }
    if(carry) res = '1' + res;
    return res;
}

int main() {
    string number;
    int K, cnt = 0;
    cin >> number >> K;
    while( K -- ){
        if(check(number)){
            break;
        }else{
            string rev = string_reverse(number);
            number = adder(rev, number);
            cnt ++;
        }
    }
    cout << number << endl << cnt; 
	return 0;
}

这题的大数相加的最后进位其实是取巧,因为两数正好是同位数的。下面给出一个采用vector的处理思路,能实现任意大数的相加。

vector<int> add(vector<int>& a, vector<int>& b)
{
    vector<int> c;
    for (int i = 0, t = 0; i < a.size() || i < b.size() || t; i ++ )
    {
        int s = t;
        if (i < a.size()) s += a[i];
        if (i < b.size()) s += b[i];
        c.push_back(s % 10);
        t = s / 10;
    }
    return c;
}

双指针遍历

bool check(vector<int>& num)
{
    for (int i = 0, j = num.size() - 1; i < j; i ++, j -- )
        if (num[i] != num[j])
            return false;
    return true;
}

总结

1. 这题的输入数字能否用int接收,一个指标是int占32位,10位大致为10的3次,32大概是10的9次,这题最好采用string接收数字。简单来说,10的10次数据不能用int接收。

2. 字符串反转,这里需要分char[]数组类型和string类型,对于char[]数组,使用strrev(s); <cstring>。或者使用reverse(s.begin(),s.end()),这个在<algorithm>中。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值