甲级PAT 1024 Palindromic Number(回文数+大数加法)

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​^10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目要求: 

还是回文数,给出一个数,判断它在Step次计算以内,每次加上自己的逆序数,能否在Step次计算内为回文数,若能则输出回文数以及相应的次数,若不能,则输出经Step次计算后的结果以及Step。

解题思路:

由于这里数可能为10^10,经100次运算之后最大可能为10^10*2^100,这个数字是非常大的。只能用字符串来处理。用很大的数组则会超过题目的空间限制。而且这里c++中字符串带有reverse()函数可实现字符串翻转,减少自己翻转的时间复杂度。只需要处理字符串相加,从下标最高位加到下标最低位。这里对于0位要单独处理,如果大于'9',则在前面单独插1。还有就是对于本身输入的数也要进行回文数的判断。

完整代码:

#include<bits/stdc++.h>
using namespace std;

int check(string s){
	int i,l=s.length();
	for(i=0;i<l/2;i++){
		if(s[i]!=s[l-i-1]) return 0;
	}
	return 1;
}

string add(string s,string t){
	int i;
	for(i=s.length()-1;i>=0;i--){
		s[i] += t[i] -'0';
		if(s[i]>'9'&&i!=0){
			s[i] -=10;
			s[i-1] +=1;
		}
	}
	if(s[0]>'9'){
		s[0] -=10;
		s.insert(0,"1");
	}
	return s;
}

int main(){
	string s,t;
	int i,step;
	cin>>s>>step;
	for(i=0;i<=step;i++){
		if(check(s)){
			cout<<s<<endl<<i;
			break;
		}
		if(i<step){
			t = s;
			reverse(t.begin(),t.end());
			s = add(s,t);
		}
	}
	if(i==step+1){
		cout<<s<<endl<<step;
	}
	return 0;
} 

小计:

之前写了个用数组存储的,然后炸了

#include<bits/stdc++.h>
using namespace std;
#define max 50

int a[max+1];
int b[max+1];

int first(){
	int i;
	for(i=0;i<=max;i++){
		if(a[i]!=0) break;
	}
	return i;
}

void add(){
	int i,k;
	k = first();
	for(i=max;i>=k;i--){
		b[i] += a[i] + a[max-i+k];
		if(b[i]>9){
			b[i-1] +=b[i]/10;
			b[i] %=10;
		}
	}
	memcpy(a,b,sizeof(b));
}

int huiwen(){
	int i,l;
	int k = first();
	for(i=k;i<k+(max+1-k)/2;i++){
		if(a[i]!=a[max+k-i]) break;
	}
	if(i!=k+(max+1-k)/2) return -1;
	else return 1;
}

int main(){
	int integ;
	int step,i,j,start=max;
	cin>>integ>>step;
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	while(integ!=0){
		a[start--] = integ%10;
		integ/=10;
	}
	for(i=0;i<step;i++){
		if(huiwen()>0){
			for(j=first();j<=max;j++) cout<<a[j]; 
			cout<<endl<<i;
			break;
		}else{
			add();
			memset(b,0,sizeof(b));
		}
	}
	if(i==step){
		for(j=first();j<=max;j++) cout<<a[j]; 
		cout<<endl<<step;
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值