除法(Division,UVa 725)

  Division 

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0through 9 once each, such that the first number divided by the second is equal to an integer N, where$2\le N \le 79$. That is,


abcde / fghij = N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer  N . An input of zero is to terminate the program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions forN.". Separate the output for two different values of N by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62

94736 / 01528 = 62

题意:输入正整数n,按从小到大的顺序输出所有形如abcde/fghij=n的表达式,其中a-j

恰好为数字0-9的一个排列(可以有前导0),2<=n<=79。

#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;

/*通过数组用来标记记录是否使用该数字。
求标记数组的和与10比较即可。 
*/
int judge(int a,int b)
{
	if(a>98765)
	{
	    return 0;
	}
	int s[10],sum=0;
	memset(s,0,sizeof(s));
	if(b<10000)
	s[0]=1;
	while(a)
	{
		s[a%10]=1;
		a/=10;
	}
	while(b)
	{
		s[b%10]=1;
		b/=10;
	}
	for(int i=0;i<10;i++)
	{
		sum+=s[i];
	}
	return (sum==10);
}
int main()
{
	int n,ans,T=0;
	while(scanf("%d",&n)&&n>=2&&n<=79)
	{
		int ans=0;
		if(T++)
		printf("\n");//注意题目格式。每两次结果间空格。 
		for(int i=1234;i<100000;i++)
		{
			if(judge(i*n,i))
			{
				printf("%05d / %05d = %d\n",i*n,i,n);
				ans=1;
			}
		}
		if(!ans)
		printf("There are no solutions for %d.\n",n);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值