1024. Palindromic Number (25)

1024. Palindromic Number (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

这是一道中等题,目的是计算一个整数的回文数字(按照上面翻译的,不知道是不是准确的翻译),何为回文数字呢,简单地说就是一个数从左到右读和从右到左读都是一样的,例如123454321,计算的整数的回文数字如上,假设整数N为67,则回文数计算为67+76=143,143+341=484,则可以得出67的回文数字为484。从题目中我们可以看到输入的整数N可以达到10^10数量级的,想想N都这么大了,回文数肯定是个很大的数字,int类型保存不了这么大的数字,故我们很自然滴想到大数运算,用string类型保存一个数字,无论数字多大都可以保存。以下的函数addBigDigit()的功能就是计算两个大数字的和。囧,今天状态不是很好,代码写得连我自己都不忍直视,不过最后还是都进过测试的了。几天就写到这吧,看下有什么新电影吧。代码如下

#include<iostream>
#include<string>
#include<cstdlib>
#include<vector>
#include<algorithm>

using namespace std;

bool isPalindromic(string& a){
	if ( a.empty() )
		return false;
	for ( int i = 0 ; i <= a.size()/2 ; i++){
		if ( a[i] != a[a.size()-i-1] )
			return false;
	}
	return true;
}

string addBigDigit( string a, string b ){
	string sum;
	int i,j,carry = 0;
	if ( a.empty() && b.empty() )
		cout<<"Error!";
	else if( a.empty() )
		return b;
	else if( b.empty() )
		return a;
	for ( i = a.size() - 1 , j = b.size() - 1;  ; i--,j--){
		if ( i < 0 && j < 0){
			if ( carry ){
				sum += 49 ;
				break;
			}else
				break;
		}
		else if ( i < 0 ){
			i = 0;
			a[i] = 48;
		}else if ( j < 0 ){
			j = 0;
			b[j] = 48;
		}
		if ( a[i] + b[j] + carry - 96 <= 9 ){
			sum += a[i] + b[j] + carry - 48;
			carry = 0;
		}else{//进位
			sum += a[i] + b[j] + carry - 58;
			carry = 1;
		}
	}
	reverse( sum.begin() , sum.end() );
	return sum;
}

string PalindromicAdd(string a){
	
	string reA = a,sum;
	reverse( reA.begin() , reA.end() );
	
	sum = addBigDigit( a , reA );

	return sum;
}

int main(){
	
	string input,Pali;
	int num,temp;
	
	cin>>input>>num;

	Pali = input;
	temp = num;

	while( num-- ){
		if ( isPalindromic( Pali ) )
			break;
		else{
			Pali=PalindromicAdd(Pali);
		}
	}
	cout<<Pali<<endl<<(temp-num-1);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值