hdoj.5090 Game with Pearls【二分图匹配】 2015/08/14

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1918    Accepted Submission(s): 674


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
 

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
 

Output
For each game, output a line containing either “Tom” or “Jerry”.
 

Sample Input
  
  
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
 

Sample Output
  
  
Jerry Tom
 

Source

注:二分图匹配匈牙利算法模板,判断匹配数是否等于n,等于,则Jerry win   否则,Tom  win
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

#define maxn 110
int g[maxn][maxn],linker[maxn];
bool vis[maxn];
int t,m,n,k;

bool dfs(int u){
    int v;
    for( v = 1 ; v <= n ; ++v ){
        if( g[u][v] && !vis[v] ){
            vis[v] = true;
            if( linker[v] == -1 || dfs(linker[v]) ){
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int solve(){
    int ret = 0;
    int u;
    memset(linker,-1,sizeof(linker));
    for( u = 1 ; u <= n ; ++u ){
        memset(vis,0,sizeof(vis));
        if( dfs(u) ) ret++;
    }
    return ret;
}

int main(){
    cin>>t;
    while(t--){
        cin>>n>>k;
        memset(g,0,sizeof(g));
        for( int i = 1 ; i <= n ; ++i ){
            scanf("%d",&m);
            while( m <= n ){
                g[m][i] = 1;
                m += k;
            }
        }
        int ans = solve();
        if( ans == n )
            printf("Jerry\n");
        else printf("Tom\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值