hdoj 5090 Game with Pearls 【二分图最大匹配】

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1913    Accepted Submission(s): 671


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
 

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
 

Output
For each game, output a line containing either “Tom” or “Jerry”.
 

Sample Input
  
  
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
 

Sample Output
  
  
Jerry Tom
 
题意:有N个管道,每个管道里面有a(1 <= a <= N)个珍珠。现在给你一个数字K,你可以选择向任何一个管道增加b个珍珠(b可以为0 或K的倍数 但不能是负数)。问你能不能通过一系列的变换 + 重排管道顺序 —— 使得:对任意一个管道 i(1<=i  <= N),它里面有 i 个珍珠。


思路:比较好想的建图。对于第i个管道,若它里面有a个珍珠,我们可以枚举出它可以达到的所有合法状态(就是管道里面的珍珠不能多于N个),并将该管道与该状态建边。然后匈牙利跑一次最大匹配,看匹配值是不是N即可。(因为共有N个状态,当N个管道全部匹配的时候,说明它们匹配的状态全都不一样,这样可以说明这个时候N个状态全部达到了)


AC代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#define MAXN 210
using namespace std;
vector<int> G[MAXN];
int a[MAXN];
int pipei[MAXN];
bool used[MAXN];
int N, K;
int find(int x)
{
    for(int i = 0; i < G[x].size(); i++)
    {
        int y = G[x][i];
        if(!used[y])
        {
            used[y] = true;
            if(pipei[y] == -1 || find(pipei[y]))
            {
                pipei[y] = x;
                return 1;
            }
        }
    }
    return 0;
}
void solve()
{
    int ans = 0;
    memset(pipei, -1, sizeof(pipei));
    for(int i = 1; i <= N; i++)
    {
        memset(used, false, sizeof(used));
        ans += find(i);
    }
    if(ans == N)
        printf("Jerry\n");
    else
        printf("Tom\n");
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &N, &K);
        for(int i = 1; i <= N; i++)
            G[i].clear();
        int a;
        for(int i = 1; i <= N; i++)
        {
            scanf("%d", &a);
            for(int j = 0; a + j <= N; j += K)//当前数字可以匹配到的数字
                G[i].push_back(a+j);
        }
        solve();
    }
    return 0;
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值