ZOJ.1577 GCD & LCM【水,暴力】 2015/09/22

GCD & LCM

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given x and y (2 <= x <= 100,000, 2 <= y <= 1,000,000), you are to count the number of p and q such that:

1) p and q are positive integers;

2) GCD(p, q) = x;

3) LCM(p, q) = y.


Input

x and y, one line for each test.


Output

Number of pairs of p and q.


Sample Input

3 60


Sample Output

4



Author: ZHOU, Qiang
Source: ZOJ Monthly, April 2003
求最大公约数与最小公倍数为x和y的p与q的组合有多少对,只要求出1~y/x内互质的书有多少对即可,WA了一次,忘了考虑y不能整除x的情况

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int gcd(int a,int b){
    return b?gcd(b,a%b):a;
}

int main(){
    int x,y;
    while( ~scanf("%d %d",&x,&y) ){
        if( y % x ){
            printf("0\n");
            continue;
        }
        int flag = y / x,ret=0;
        for( int i = 1 ; i <= flag ; ++i ){
            if( flag % i == 0 ){
                if( gcd(i,flag/i) == 1 )
                    ret++;
            }
        }
        printf("%d\n",ret);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值