ZOJ 1577 GCD & LCM 数论

GCD & LCM

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given x and y (2 <= x <= 100,000, 2 <= y <= 1,000,000), you are to count the number of p and q such that:

1) p and q are positive integers;

2) GCD(p, q) = x;

3) LCM(p, q) = y.


Input

x and y, one line for each test.


Output

Number of pairs of p and q.


Sample Input

3 60


Sample Output

4



import java.io.BufferedReader;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.math.BigInteger;
import java.util.HashMap;
import java.util.Map;
import java.util.StringTokenizer;


public class Main {
    public static void main(String[] args){
    	new Task().solve() ; 
	}
}

class Task{
	InputReader in = new InputReader(System.in) ;
	PrintWriter out = new PrintWriter(System.out) ;
	
	Map<Integer , Integer>  gao(int num){
		Map<Integer , Integer> facs = new HashMap<Integer, Integer>() ;
		for(int i = 2 ; i*i <= num ; i++){
			if(num % i == 0){
				int cnt = 0 ; 
				while(num % i == 0){
					cnt++ ;
					num /= i ; 
				}
				facs.put(i , cnt) ;
			}
		}
		if(num != 1)  facs.put(num , 1) ;
		return facs ;
	}
	
	long sum(Map<Integer , Integer> gcd , Map<Integer , Integer> lcm){
		long res = 1L ;
		int vis = 0 ;
		for(Map.Entry<Integer, Integer> entry : gcd.entrySet()){
			Integer fac = entry.getKey() ;
			Integer gcdcnt = entry.getValue() ;
			Integer lcmcnt = lcm.get(fac) ;
			if(lcmcnt == null || gcdcnt > lcmcnt) return 0L ;
			res *= (gcdcnt == lcmcnt) ? 1L : 2L ;
			vis++ ;
		}
		return res * (long)Math.pow(2.0 , lcm.size()-vis) ; 
	}
	
	void solve(){
		while(in.hasNext()){
			out.println(sum(gao(in.nextInt()), gao(in.nextInt()))) ; 
			//out.flush();  
		}
		out.flush();  
	}
}


class InputReader {  
    public BufferedReader reader;  
    public StringTokenizer tokenizer;  
  
    public InputReader(InputStream stream) {  
        reader = new BufferedReader(new InputStreamReader(stream), 32768);  
        tokenizer = new StringTokenizer("");  
    }  
  
    private void eat(String s) {  
        tokenizer = new StringTokenizer(s);  
    }  
  
    public String nextLine() {  
        try {  
            return reader.readLine();  
        } catch (Exception e) {  
            return null;  
        }  
    }  
  
    public boolean hasNext() {  
        while (!tokenizer.hasMoreTokens()) {  
            String s = nextLine();  
            if (s == null)  
                return false;  
            eat(s);  
        }  
        return true;  
    }  
  
    public String next() {  
        hasNext();  
        return tokenizer.nextToken();  
    }  
  
    public int nextInt() {  
        return Integer.parseInt(next());  
    }  
  
    public long nextLong() {  
        return Long.parseLong(next());  
    }  
  
    public double nextDouble() {  
        return Double.parseDouble(next());  
    }  
  
    public BigInteger nextBigInteger() {  
        return new BigInteger(next());  
    }  
  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值