zoj 1577 GCD & LCM

GCD & LCM

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given x and y (2 <= x <= 100,000, 2 <= y <= 1,000,000), you are to count the number of p and q such that:

1) p and q are positive integers;

2) GCD(p, q) = x;

3) LCM(p, q) = y.


Input

x and y, one line for each test.


Output

Number of pairs of p and q.


Sample Input

3 60


Sample Output

4


解题思路:我们由GCD(p,q)=x,可以假设p=ax,q=bx(a,b互质),那么LCM(p,q)=abx=y,即abx=y,其中a、b互质,所以当y%x!=0时不存在,如果存在,那么我们可以枚举a;

参考代码:

#include <iostream>
using namespace std;
int gcd(int a,int b){
	if(b==0)	return a;
	return gcd(b,a%b);
}
int solve(int k){
	int ans=1;
	for (int i=2;i*i<=k;i++){
		if (k%i==0){
			if (gcd(k/i,i)==1)
				ans++;
		}
	}
	return ans*2;
}
int main(){
	int x,y;
	while (cin>>x>>y){
		if (y%x!=0)
			cout<<0<<endl;
		else if (x==1)
			cout<<2<<endl;
		else if (x==y)
			cout<<1<<endl;
		else{
			int k=y/x;
			cout<<solve(k)<<endl;

		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值