ZOJ.2421 Recaman's Sequence【暴力打表】 2015/09/24

Recaman's Sequence

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The Recaman's sequence is defined by a0 = 0 ; for m > 0, am = am-1 - m if the rsulting am is positive and not already in the sequence, otherwise am = am-1 + m.

The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9... . Given k, your task is to calculate ak.


Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. The last line contains an integer -1, which should not be processed.


Output

For each k given in the input, print one line containing ak to the output.


Sample Input

7
10000
-1


Sample Output

20
18658


Source: Asia 2004, Shanghai (Mainland China), Preliminary
直接打表

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

bool p[9000010];
int a[500010];

void init(){
    memset(p,false,sizeof(p));
    a[0] = 0;
    for( int i = 1 ; i <= 500000 ; ++i ){
        if( a[i-1] - i <= 0 || p[a[i-1]-i] )
            a[i] = a[i-1] + i;
        else a[i] = a[i-1] - i;
        p[a[i]] = true;
    }
}

int main(){
    init();
    int n;
    while( ~scanf("%d",&n) ){
        if( n == -1 ) break;
        printf("%d\n",a[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值