PTA.5-1 复数相加

5-1 复数相加   (14分)

题目:一个复数类,运算符重载 + ,实现复数和复数的相加。输入一组复数,每行一个复数,直到输入0结束。 输出这组复数的结果。

提示: 复数的输入和输出符合数学书写规范

输入示例

3+2i

2+3i

0

输出示例

5+5i



代码:

// 练习一.cpp : 定义控制台应用程序的入口点。
//


#include "stdafx.h"


#include<iostream>
#include<cstring>
using namespace std;
class complex
{
  public:
	  complex(double r = 0.0, double i = 0.0)
	  {
		  real = r;
		  imag = i;
	  }
	  void display()
	  {
		  cout << real << "+" << imag << "i";
	  }
	  complex operator +(const complex& a)
	  {
		  real = real + a.real;
		  imag = imag + a.imag;
		  return *this;
	  }
	double real=0;
	double imag=0;


};
int main()
{
	complex a, b(0, 0);
	char c, d;
	double q = 100;
	while (1)
	{
		cin >> a.real;
		q = a.real;
		if (q == 0) break;
		cin >> c >> a.imag >> d;
		b = a + b;
	}
	b.display();
	getchar();
	return 0;
}


  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值