poj 1118 Lining Up (暴力)

Lining Up

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 20910 Accepted: 6569

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source

East Central North America 1994
#include <stdio.h>
int data[705][2];
/**
 * 题目大意:给n个点的坐标,求一条直线最多能穿过多少个点
 * 解题方法:完全的暴力,将所有情况遍历一遍,算出最大值
 */
#define MAX(a, b) ((a) > (b) ? (a) : (b))
int main()
{
//	freopen("in.txt", "r", stdin);
	int n;
	while(scanf("%d", &n) == 1)
	{
		if(n == 0)
		{
			break;
		}
		int i, j, k;
		for(i = 0; i < n; ++ i)
		{
			scanf("%d%d", &data[i][0], &data[i][1]);
		}
		int res = 0;
		for(i = 0; i < n; ++ i)
		{
			for(j = i + 1; j < n; ++ j)
			{
				int restemp = 0;
				for(k = j + 1; k < n; ++ k)
				{
					if((data[i][1] - data[j][1]) * (data[i][0] - data[k][0]) == \
							(data[i][1] - data[k][1]) * (data[i][0] - data[j][0]))
					{
						++ restemp;
					}
				}
				res = MAX(res, restemp);
			}
		}
		printf("%d\n", res + 2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值