POJ1118 Lining up

Lining Up
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 19392 Accepted: 6133

Description

"How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 


Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source

给你几个点,求一条直线最多经过几个点。
个人纯暴力。
这题网上貌似说hash可以做,不懂啊,会的大神来给我讲讲啊
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    double x,y;
} p[701];
bool v[701][701];
int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)return 0;
        memset(v,0,sizeof(v));
        for(int i=0; i<n; i++)scanf("%lf%lf",&p[i].x,&p[i].y);
        int a=0,b;
        for(int i=0; i<n-1; i++)
        {
            for(int j=i+1; j<n; j++)//我是以两个点为基点,看还有木有其他点在这两个点所构成的直线上
            {
                if(v[i][j]==1)continue;//这是优化
                b=0;
                //double k=(p[i].y-p[j].y)/(p[i].x-p[j].x);
                //double c=k*p[j].x-p[j].y;
                for(int u=0; u<n; u++)
                {
                    if((p[u].y-p[i].y)*(p[j].x-p[i].x)==(p[j].y-p[i].y)*(p[u].x-p[i].x))//为了精度准确,尽量少用除号,我因此wa过1次
                    {
                        b++;
                    v[i][u]=1;//优化
                    v[u][i]=1;
                    v[u][j]=1;
                    v[j][u]=1;}
                }
                if(b>a)a=b;
            }
        }
        cout<<a<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值