HDU 1711 Number Sequence 【KMP】

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33291    Accepted Submission(s): 13910


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
#include<bits/stdc++.h>
using namespace std;
#define mms(x) memset(x, 0, sizeof x)
const int MAX = 1e6 + 7;
int _next[MAX], a[MAX], b[MAX];
int len1, len2;
void getnext()
{
    int i = 0, j = -1;
    _next[0] = -1;
    while(i < len2)
        if(j == -1 || b[i] == b[j])
        {
            i++;
            j++;
            _next[i] = j;
        }
        else
            j = _next[j];
}
int kmp()
{
    int i = 0, j = 0;
    while(i < len1 && j < len2)
    {
        if(j == -1 || a[i] == b[j])
        {
            i++;
            j++;
        }
        else
            j = _next[j];
    }
    if(j >= len2)
        return i - len2 + 1;
    return 0;
}
int main()
{
    int N;
    cin >> N;
    while(N--)
    {
        cin >> len1 >> len2;
        mms(_next);
        for(int i = 0; i < len1; i++)
            cin >> a[i];
        for(int i = 0; i < len2; i++)
            cin >> b[i];
        getnext();
        if(!kmp())
            cout << "-1" << endl;
        else
            cout << kmp() << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值