HDU 3605 Escape 【二分图多重匹配】

Escape

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 12530    Accepted Submission(s): 3096


 

Problem Description

2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.

 

 

Input

More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000

 

 

Output

Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.

 

 

Sample Input

 

1 1 1 1 2 2 1 0 1 0 1 1

 

 

Sample Output

 

YES NO

#include<bits/stdc++.h>
using namespace std;
int n, m;
int vis[15];
int a[100005][15], p[15][100005];
int M[15], cnt[15];
bool dfs(int x){
    for(int i = 0; i < m; i++){
        if(a[x][i] && !vis[i]){
            vis[i] = 1;
            if(cnt[i] < M[i]){
                p[i][cnt[i]++] = x;
                return 1;
            }
            for(int j = 0; j < cnt[i]; j++){
                if(dfs(p[i][j])){
                    p[i][j] = x;
                    return 1;
                }
            }
        }
    }
    return 0;
}
void match(){
    memset(p, -1, sizeof p);
    for(int i = 0; i < n; i++){
        memset(vis, 0, sizeof vis);
        if(!dfs(i)){
            puts("NO");
            return;
        }
    }
    puts("YES");
    return;
}
int main(){
    while(scanf("%d%d", &n, &m) != EOF){
        memset(cnt, 0, sizeof cnt);
        for(int i = 0; i < n; i++) for(int j = 0; j < m; j++)
            scanf("%d", &a[i][j]);
        for(int i = 0; i < m; i++) scanf("%d", &M[i]);
        match();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值