hdu 2004 成绩转换

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=2004

成绩转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 85971    Accepted Submission(s): 37811


Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
 

Input
输入数据有多组,每组占一行,由一个整数组成。
 

Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
 

Sample Input
  
  
56 67 100 123
 

Sample Output
  
  
E D A Score is error!
 

Author
lcy
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1090  1092  1096  1089  1095 
 

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

char SwitchScore(int a)
{
    if(a >= 90 && a <= 100)
        return 'A';
    else if(a >= 80)
        return 'B';
    else if(a >= 70)
        return 'C';
    else if(a >= 60)
        return 'D';
    else
        return 'E';
}

int main()
{
    int iScore;
    while(~scanf("%d", &iScore))
    {
        if(iScore > 100 || iScore < 0)
            printf("Score is error!\n");
        else
            printf("%c\n", SwitchScore(iScore));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值