POJ-3784 Running Median(对顶堆动态维护中位数)

POJ-3784 Running Median(对顶堆动态维护中位数)

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3 
1 9 
1 2 3 4 5 6 7 8 9 
2 9 
9 8 7 6 5 4 3 2 1 
3 23 
23 41 13 22 -3 24 -31 -11 -8 -7 
3 5 103 211 -311 -45 -67 -73 -81 -99 
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3 
-7 -3

代码显而易见我不解释了

/*POJ - 3784*/
#include<cstdio>
#include<iostream>
#include<queue>
#define int long long
typedef long long ll;
#define js ios::sync_with_stdio(0);cin.tie(0);cout.tie(0);
using namespace std;
priority_queue<int,vector<int>,less<int> > q1;
priority_queue<int,vector<int>,greater<int> > q2;
signed main(){
    js;
    int p;
    cin>>p;
    while(p--){
        while(!q1.empty()) q1.pop();
        while(!q2.empty()) q2.pop();
        int id,n,x;
        cin>>id>>n;
        cout<<id<<" "<<(n+1)/2<<endl;
        cin>>x;cout<<x;
        q1.push(x);
        int cnt=1;
        for(int i=2;i<=n;i++){
            cin>>x;
            if(x<q1.top()) q1.push(x);
            else q2.push(x);
            if(i&1){
                if(cnt==10){
                    cout<<endl;
                    cnt=0;
                }else{
                    cout<<" ";
                }
                if(q1.size()>q2.size()) cout<<q1.top();
                else cout<<q2.top();
                cnt++;
            }else{
                if(q1.size()>q2.size()){
                    q2.push(q1.top());
                    q1.pop();
                }
                if(q1.size()<q2.size()){
                    q1.push(q2.top());
                    q2.pop();
                }
            }

        }
        cout<<endl;
    }
    
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值