joj 1195

 1195: Prime Ring Problem


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
10s 8192K 1939 493 Standard

A ring is composed of n circles as shown in diagram. Put natural numbers into each circle separately, and the sum of numbers in two adjacent circles should be a prime.


Note: the number of first circle should always be 1.

Input

n (0 < n <= 16)

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.


You are to write a program that completes above process.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


This problem is used for contest: 102  150 


Submit / Problem List / Status / Discuss




#include<cstdio>

int prime[33];
int visited[17];
int num[17];
void findprime()
{
    for(int i=1;i<=32;i++)prime[i]=1;
    for(int i=2;i<=16;i++)
    {
        for(int j=2;i*j<=32;j++)
        {
            prime[i*j]=0;
        }
    }
}
void print(int selected,int n)
{
    if(selected==n)
    {
        if(prime[num[n]+1]==0)return ;
        for(int i=1;i<n;i++)printf("%d ",num[i]);
        printf("%d\n",num[n]);
        return ;
    }
    for(int i=2;i<=n;i++)
    {
        if(visited[i]==0&&prime[i+num[selected]]==1)
        {
            visited[i]=1;
            int m=selected+1;
            num[m]=i;


            print(m,n);
            visited[i]=0;
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    findprime();
    int count=1;
    while(scanf("%d",&n)==1)
    {
        printf("Case %d:\n",count++);
        if(n!=1)
        {
            for(int i=1;i<=n;i++)visited[i]=0;
            num[1]=1;
            visited[1]=1;
            print(1,n);
        }


        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值