joj1197


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K694275Standard

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing ` Sums of ', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ` NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


This problem is used for contest: 60  149 


Submit / Problem List / Status / Discuss


 

 

#include<cstdio>
#include<string.h>
int store[15];
int temp[15][15];//用于储存已经找到的那些数字
int out[15];
int sum;
int t,n;
void find(int place,int selected,int ss)
{
    for(int i=place;i<=n;i++)
    {
        if(store[i]+ss<t)
        {
            out[selected+1]=store[i];
            find(i+1,selected+1,ss+store[i]);
        }
        else if(store[i]+ss==t)
        {
            out[selected+1]=store[i];
            out[selected+2]=0;/*这个赋值是必须要有的因为很可能out【selected+2】在前面已经被修改了
我就是因为缺少这个赋值提交了好几次都没有通过*/
            int tt=0;
            bool tp;
            for(int k=1;k<=sum;k++)
            {
                tp=false;
                int u;
                for(u=1;out[u]!=0;u++)
                {
                    if(temp[k][u]!=out[u])
                    {
                        tp=true;
                        tt++;
                        break;
                    }
                }
                if(tp==false&&temp[k][u]!=-1)tt++;
            }
            if(tt==sum)
            {
                sum++;
                int u=1;
                printf("%d",out[1]);
                temp[sum][1]=out[1];
                for(u=2;out[u]!=0;u++)
                {
                    printf("+%d",out[u]);
                    temp[sum][u]=out[u];
                }
                printf("\n");
                temp[sum][u]=-1;
            }
        }
    }
}
int main()
{
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
    while(scanf("%d%d",&t,&n),t&&n)
    {
        sum=0;
        for(int i=1;i<=n;i++)
        scanf("%d",&store[i]);
        memset(temp,0,sizeof(temp));
        printf("Sums of %d:\n",t);
        find(1,0,0);
        if(sum==0)printf("NONE\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值