joj1583

 1583: Let Me Count The Ways


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s 8192K 551 231 Standard

After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny, nickel, dime, quarter, half-dollar) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 99 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.


This problem is used for contest: 109 


Submit / Problem List / Status / Discuss



#include<stdio.h>
#include<iostream>
using namespace std;
int c1[100];
int c2[100];
int a[]={1,5,10,25,50};
int main()
{
    for(int i=0;i<=100;i++)
    {
        c1[i]=1;c2[i]=0;
    }
    int n=100;
    for(int i=1;i<=4;i++)
    {
        for(int j=0;j<=n;j++)
        {
            for(int k=0;k+j<=n;k+=a[i])
            {
                c2[j+k]+=c1[j];
            }
        }
        for(int i=0;i<=n;i++)
        {
            c1[i]=c2[i];
            c2[i]=0;
        }
    }
    while(scanf("%d",&n)==1)
    {
        if(c1[n]>1)
        cout<<"There are "<<c1[n]<<" ways to produce "<<n<<" cents change."<<endl;
        else
        cout<<"There is only "<<c1[n]<<" way to produce "<<n<<" cents change."<<endl;
    }
    return 0;
}

//跟1424一样的都是母函数应用,具体的可以看我转载的母函数详解


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值