九度oj-1038-Sum of Factorials

题目描述:

    John von Neumann, b. Dec. 28, 1903, d. Feb. 8, 1957, was a Hungarian-American mathematician who made important contributions to the foundations of mathematics, logic, quantum physics, meteorology, science, computers, and game theory. He was noted for a phenomenal memory and the speed with which he absorbed ideas and solved problems. In 1925 he received a B.S. diploma in chemical engineering from Zurich Institute and in 1926 a Ph.D. in mathematics from the University of Budapest, His Ph.D. dissertation on set theory was an important contributions to the subject.
    At the age of 20, von Neumann proposed a new definition of ordinal numbers that was universally adopted. While still in his twenties, he made many contributions in both pure and applied mathematics that established him as a mathematician of unusual depth. His Mathematical Foundation of Quantum Mechanics (1932) built a solid framework for the new scientific discipline.
    During this time he also proved the mini-max theorem of GAME THEORY. He gradually expanded his work in game theory, and with coauthor Oskar Morgenstern he wrote Theory of Games and Economic Behavior (1944).
    There are some numbers which can be expressed by the sum of factorials. For example 9, 9 = 1! + 2! + 3! . Dr. von Neumann was very interested in such numbers. So, he gives you a number n, and wants you to tell whether or not the number can be expressed by the sum of some factorials.
Well, it is just a piece of case. For a given n, you will check if there are some xi, and let n equal to Σt (上标) i=1(下标) xi! (t≥1, xi≥0, xi = xj <==> i = j)
           t
     即 Σ  xi! (t≥1, xi≥0, xi = xj <==> i = j)
          i=1
    If the answer is yes, say "YES"; otherwise, print out "NO".

输入:

    You will get a non-negative integer n (n≤1,000,000) from input file.

输出:

    For the n in the input file, you should print exactly one word ("YES" or "NO") in a single line. No extra spaces are allowed.

样例输入:
9
2
样例输出:
YES
YES


AC代码:

#include<stdio.h>

int main(){

	int s[10];
	s[0]=1;
	int i;
	int n;
	for(i=1;i<10;i++){
		s[i]=s[i-1]*i;
	}

	while(scanf("%d",&n)!=EOF){
		if(n==0) return 0;
		int j;
		for(j=9;j>=0;j--){
			if(n>=s[j]) n-=s[j];
			if(n==0) break;
		}
		if(n==0){
			printf("YES\n");
		}else{
			printf("NO\n");
		}
	}

	return 0;
}

WA代码:

#include<stdio.h>

int main(){

	int s[10];
	s[0]=1;
	int i;
	int n;
	for(i=1;i<10;i++){
		s[i]=s[i-1]*i;
	}

	while(scanf("%d",&n)!=EOF){
		if(n==0) return 0;
		int j;
		/*for(j=9;j>=0;j--){
			if(n>=s[j]) n-=s[j];
			if(n==0) break;
		}*/
		int sum=0;
		int flag=0;
		
		for(j=0;j<10;j++){
			if(n>sum) sum+=s[i];
			else if(n>sum) break;
			else {
				flag=1;
				break;
			}
			
		}

		if(flag){
			printf("YES\n");
		}else{
			printf("NO\n");
		}
	}

	return 0;
}

开始没读清题,以为只是普通的那个连续阶乘求和,那示例中的2就不应该是yes呀。仔细读了,发现是be expressed by the sum of some factorials. 是some!!!

那个错误的代码是我理解错的。。。

中间还各种理解错误,看它写了个xi=xj<=>i=j,以为可以重复,那这样也不对。

后来真想不出去查了一下,说用贪心算法,就去学习了一下。

嘛~最后就是这样了。

下一题。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值