POJ3984迷宫问题——题解

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

原题链接

简单思路

dfs思路:

普通的搜索。(很水)

bfs思路:

将每个能走得边存入队列,如果当前点在右下角break

存路径思路:

一个node类型的二维数组,每个点记录,他从那来。
最后用递归输出路径。

void print(node tmp) {
	if (tmp.x == 0 && tmp.y == 0) {
		cout << "(0, 0)" << endl;
		return ;
	}
	print(path[tmp.x][tmp.y]);
	cout << "(" << tmp.x << ", " << tmp.y << ")" << endl;
}

最后附上完整代码

#include <iostream>
#include <queue>

using namespace std;

struct node {
	int x, y;
};
int a[10][10], vis[11][11];
node path[110][110];
int dir[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};

void print(node tmp) {
	if (tmp.x == 0 && tmp.y == 0) {
		cout << "(0, 0)" << endl;
		return ;
	}
	print(path[tmp.x][tmp.y]);
	cout << "(" << tmp.x << ", " << tmp.y << ")" << endl;
}

int main() {
	for (int i = 0; i < 5; i++) {
		for (int j = 0; j < 5; j++) {
			cin >> a[i][j];
		}
	}
	queue <node> q;
	node ttt;
	ttt.x = 0, ttt.y = 0;
	q.push(ttt);
	vis[0][0] = 1;
	while (!q.empty()) {
		node now = q.front();
		q.pop();
		if (now.x == 4 && now.y == 4) break;
		for (int i = 0; i < 4; i++) {
			node nod;
			nod.x = now.x + dir[i][0];
			nod.y = now.y + dir[i][1];
			if (nod.x >= 0 && nod.x < 5 && nod.y >= 0 && nod.y < 5 && vis[nod.x][nod.y] == 0 && a[nod.x][nod.y] == 0) {
				vis[nod.x][nod.y] = 1;
				q.push(nod);
				path[nod.x][nod.y] = now;
			}
		}
	}
	node t;
	t.x = 4, t.y = 4;
	print(t);
	return 0;
	//完成
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值