BFS——POJ 3984 迷宫问题 解题题解

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


解题思路:

BFS入手,记录上一步位置,最后输出最短路径。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
struct tep
{
	int x,y,cnt;
};
int maze[5][5],vis[5][5],dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
tep cur,next, road[5][5],ans[100];

void bfs()
{
	queue<tep> p;
	while(!p.empty())
	{
		p.pop();
	}
	memset(vis, 0, sizeof(vis));
	cur.x = cur.y = cur.cnt = 0;
	p.push(cur);
	while(!p.empty())
	{
		cur = p.front();
		p.pop();
		for(int i = 0; i < 4; i++)
		{
			int tx = cur.x + dir[i][0];
			int ty = cur.y + dir[i][1];
			if(maze[tx][ty] != 1 && tx >= 0 && tx <= 4 &&ty >=0 &&ty <= 4)
			{
				maze[tx][ty] = 1;
				next.x = tx;
				next.y = ty;
				next.cnt = cur.cnt + 1;
				road[next.x][next.y].x = cur.x;
				road[next.x][next.y].y = cur.y;
				p.push(next);
			}
			if(cur.x == 4 &&cur.y == 4)
				return ;
		}
	}
	
}


int main()
{
	memset(maze, 0, sizeof(maze));
	for(int i = 0; i < 5; i++)
		for(int j = 0; j < 5; j++)
		{
			scanf("%d", &maze[i][j]);
		}
	bfs();
	int xx = 4, yy = 4;
	for(int i = 0;i < cur.cnt; i++)
	{
		ans[i].x = road[xx][yy].x;
		ans[i].y = road[xx][yy].y;
		xx = ans[i].x;
		yy = ans[i].y;
	}
	for(int i = cur.cnt - 1 ; i >= 0; i--)
	{
		printf("(%d, %d)\n", ans[i].x, ans[i].y);
	}
	printf("(4, 4)\n");
	return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值