POJ 2533 Longest Ordered Subsequence

                                     Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 59959 Accepted: 26861

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4 

题意概括:输入n个数,求出这n个数的最长的最长不下降子序列

解题思路:朴素动态规划。设置两层循环,外层循环从下标2开始,到最后一个数;内层循环从下标1开始,到i- 1。每次从第i个数的dp开始询问,如果第i个数大于第j个数,就让dp从第j个数的dp加1,与第i个数的dp比较。取最大的那一个。同时在外重循环比较每一次的第i个dp,找出最大的那一个。

AC代码:

#include<stdio.h>
#include<algorithm>
#define N 100005
using namespace std;

int main(void)
{
	int n, i, j, a[N], dp[N], longst = 1;
	scanf("%d", &n);
	for(i = 1; i <= n; i ++)
	{
		scanf("%d", &a[i]);
		dp[i] = 1;
	}
	for(i = 2; i <= n; i ++)
	{
		for(j = 1; j <= i - 1; j ++)
		{
			if(a[i] > a[j])
			{
				dp[i] = max(dp[j] + 1, dp[i]);
			}
		}
		longst = max(dp[i], longst);
	}
	
	printf("%d\n", longst);
	return 0;
}
错误原因:边界数据。当输入为1个数时,应当输出1,因此longst的初值不能置为负数,不然会输出负数。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值