POJ-2533-Longest Ordered Subsequence

点击打开链接


Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 54246 Accepted: 24264

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
题意:找出最长递增子序列

有两种方法,第一种按模板

第二种用lower_bound(begin,end+1,k)函数,该函数用于在区间begin,end范围内,找出第一个大于等于k的数,返回地址

但是方法二不用刻意追求原因,知道怎么用就行了,最快的方法

方法一:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n,a[1005],maxi[1005];	//maxi表示以第i个数结尾,最长子序列长度,不算本身
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		memset(maxi,0,sizeof(maxi));
		maxi[0]=1;
		for(int j=1;j<n;j++)
		{
			int num=0;		
			for(int i=0;i<j;i++)
			{
				if(a[i]<a[j]&&num<maxi[i])
				num=maxi[i];
			}
			maxi[j]=num+1;	//加上自身
		}
		sort(maxi,maxi+n,cmp);	//将所有序列长度从大到小排序
		printf("%d\n",maxi[0]);
	}
	return 0; 
} 

方法二:

#include <cstdio>  
#include <algorithm>  
#define INF 0x3f3f3f  
using namespace std;  
int dp[30010],a[30010];  
int main()  
{  
    int n,i,j;  
    while(scanf("%d",&n)!=EOF)  
    {  
        for(i=0;i<n;++i)  
        {  
            scanf("%d",&a[i]);  
            dp[i]=INF;  
        }  
        for(i=0;i<n;++i)  
            *lower_bound(dp,dp+n,a[i])=a[i]; 	//找到第一个大于等于a[i]的数,并用a[i]替换 
        printf("%d\n",lower_bound(dp,dp+n,INF)-dp);   //最终区间长度即为最长子序列个数
    }  
    return 0;  
}   



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值