poj-2406 Power Strings(kmp-字符串的循环次数)

                                                      题目链接:http://poj.org/problem?id=2406

                                                                           Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 60403 Accepted: 25003

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

题意:给出一个字符串,输出循环次数,如果不是循坏串,就输出 1即可。

解题思路:记清楚循环串的性质len%(len-next[len])==0,次数是len/(len-next[len]).

代码:

#include <stdio.h>
#include <string.h>
#define N 1000000 
int next[N];

void getnext(char s[])
{
	int j=0;
	int  k=-1;
	int len=strlen(s);
	next[0]=-1;
	while(j<len)
	{
		if(k==-1||s[j]==s[k])
		{
			j++;
			k++;
			next[j]=k;
		}
		else
			k=next[k];
	}
}
int main()
{
	int l;
	char s[N];
	while(scanf("%s",s)!=EOF)
	{
		if(s[0]=='.')
			break;
		getnext(s);
		l=strlen(s);
		if(l%(l-next[l])==0)
			printf("%d\n",l/(l-next[l]));
		else
			printf("1\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值